Saitek X65 Probleme

  • Hi Männer,

    der Geist ist willig, aber das Fleisch ist schwach... nun wollte ich endlich die Maschine zum Laufen bringen um wieder in den Flugbetrieb einzusteigen, jedoch bin ich nicht sehr weit gekommen:


    Mein Saitek X65 streikt. Beim Einstecken gehen die Lichter nur ganz schwach an und Windows zeigt mir kryptische Treiberprobleme an:



    Ich habe es mit dem Saitek_X65F_Flight_Controller_7_0_53_6_x64_Drivers versucht, mein Windows ist auf Version 1809.



    Kann jemand mit dem Problem etwas anfangen? Fehlen Informationen - Versionen etc?


    Danke im Voraus und viele Grüße!
    Kiwi

  • Moin Kiwi


    An welchem USB haste den denn angesteckt?

    USB3 versuchen, und die Treiber als Admin Installieren...

    Vermutlich auch eine runtime.dll Datei die noch fehlt die Windows brauch.

    Ist auf jedenfall kein Treiberprob., sondern Win10 , ist ja noch Neu....;)


    Badcrow hat da einen Link und kann dir sagen wie du das machen kannst, hat auch schon

    anderen in der Geschichte geholfen der Gute...:thumbup:


    Gruß Hunter8)

  • zu langes usb Kabel? Ich hatte bei mir ne Verlängerung. Damit hat es nicht funktioniert. Ohne geht es

    _________________________________________________________________________________________________________

    A superior pilot uses his superior judgement to avoid situations which require the use of his superior skill

    Frank Bormann, Apollo 8

  • Moinsen,

    danke erstmal für die Tipps!

    zu langes usb Kabel? Ich hatte bei mir ne Verlängerung. Damit hat es nicht funktioniert. Ohne geht es

    Ne, direkt am Mobo eingestreckt, das war es nicht.



    Vielleicht hilft das hier?

    War das erste Ergebnis bei Google und klingt ein bisschen danach: http://www.72ndvfw.org/forum/m…ssue-on-windows-10-solved

    Das habe ich auch gefunden, leider hat es nicht geholfen.



    Ich habs mir leicht gemacht und einfach mein System neu aufgesetzt... Immerhin wird der Stick schon einmal erkannt. Allerdings gibt es jetzt neue Baustellen - der Mode-Schalter, welchen ich für die MRM/DGFT Overridemodi genutzt habe, sendet nun durchgehend den Keystroke (zB dddddddddddd) statt, wie unter Windows 7, ein einziges Mal "d". Ich werde da erstmal weiterwühlen... Es gibt dazu einen Beitrag im BMS Forum, allerdings ohne Lösung.


    VG

    Kiwi

  • Hier würde ich keinen Mix machen!!!!

    Geh komplett auf DirectX. Zu dem Override Button: In der BMS Config muss ein entsprechender Eintrag zu Canceln des Befehls gesetzt werden. Über DirectX ist es sehr leicht programmierbar da man über die Modifier das Verhalten des Inputs beeinflussen kann.


    Können gern einen Termin im TS machen. Das ist fix erklärt und programmiert. Vergiss die Saitek SW.


    Gruß

    Keule

    -------------------------------------------------
    There are only two types of aircraft - fighters and targets.
    (Doyle 'Wahoo' Nicholson)

    signatur_keule.png

  • Hallöle,

    mit den neuesten Treibern, die ich auftreiben konnte, kann ich nun den Mode-Switch für die MRM/DGFT Overrides nutzen - super. Jetzt das nächste Problem:


    Der Falke zieht nach links! Ich habe die größtmöglichen Deadzones an Stick und Rudern ausprobiert, dennoch dreht sich das Flugzeug trotz 0 Eingabe am Stick immer nach links. Ein Problem der Trimmung/assymetrisches Loadout? Vielleicht hatte ja mal jemand dieses Problem...

  • Hallo Kiwi,

    ich habe auch den X65 und hatte das gleiche Problem. Bei mir war einer der beiden Drehregler auf der Throttle-Base autom. als Trimmungsachse konfiguriert

    worden. Der Regler stand natürlich nicht auf "Null" und so zog der Flieger immer zur Seite.

    Kontrolliere mal Deine Achsenzuweisungen.


    Gruß

    Skipper

  • Hi Kiwi


    Hast du noch andere Controller an irgendeinem USB hängen?


    Dann Stöpsel die mal ab und versuch es nochmal.


    Falls dies kein Erfolg bringt dann schau mal unter Gamecontroller ob dort die Achsen korrekt

    funktionieren.


    Eventuell schau mal in dem BMS / User/ Config ob dort die Datei "Device Sorting" schreibgeschützt ist.

    Wenn ja mach mal den Schreibschutz raus und starte den Falcon neu.

    Sollte unter Controller /Advanced der Stick nun funktionieren dann schließe den Falcon und mach bei "

    "Device Sorting" den Schreibschutz wieder rein.


    Gruß Hunter8)

  • Hi, ich glaube, dass Cupra Recht hatte - das Ziehen zur Seite tritt nur bei asynchronen Beladungen wie z.B. einem Target Pod auf.

    Wie war bei dem Flug die Beladung?`


    Sachen wie HTS, Target-Pod etc. beeinflussen jetzt das Flugverhalten. Das war bis 4-34 nicht so...

    Ist die Lösung da das manuelle Trimmen?